update CI for ubuntu 20.04 deprecation (#348) * update CI for ubuntu 20.04 deprecation * Update setup.py * Update ci.yml
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml index 1ba5f7e..b37ddd6 100644 --- a/.github/workflows/ci.yml +++ b/.github/workflows/ci.yml
@@ -10,7 +10,7 @@ jobs: mypy: - runs-on: ubuntu-20.04 + runs-on: ubuntu-22.04 steps: - uses: actions/checkout@11bd71901bbe5b1630ceea73d27597364c9af683 # v4.2.2 @@ -22,11 +22,10 @@ run: mypy --strict certifi test: - runs-on: ubuntu-20.04 + runs-on: ubuntu-22.04 strategy: matrix: python-version: - - "3.6" - "3.7" - "3.8" - "3.9" @@ -34,6 +33,7 @@ - "3.11" - "3.12" - "3.13" + - "3.14-dev" steps: - uses: actions/checkout@11bd71901bbe5b1630ceea73d27597364c9af683 # v4.2.2 - name: Set up Python ${{ matrix.python-version }}
diff --git a/setup.py b/setup.py index 50ddd9f..f3a1763 100755 --- a/setup.py +++ b/setup.py
@@ -36,11 +36,10 @@ ], package_dir={"certifi": "certifi"}, package_data={"certifi": ["*.pem", "py.typed"]}, - # data_files=[('certifi', ['certifi/cacert.pem'])], include_package_data=True, zip_safe=False, license="MPL-2.0", - python_requires=">=3.6", + python_requires=">=3.7", classifiers=[ "Development Status :: 5 - Production/Stable", "Intended Audience :: Developers", @@ -49,7 +48,6 @@ "Programming Language :: Python", "Programming Language :: Python :: 3", "Programming Language :: Python :: 3 :: Only", - "Programming Language :: Python :: 3.6", "Programming Language :: Python :: 3.7", "Programming Language :: Python :: 3.8", "Programming Language :: Python :: 3.9",